【分享】哪个OS X版本支持哪个Xcode的版本?

【分享】哪个OS X版本支持哪个Xcode的版本?

在安装Xcode时,会碰到跟OS X操作系统匹配的问题,对照下下面几个表,以免给自己带来编译不过或者奇怪的错误等问题

以下列表来自网络:

Xcode 1.0 - Xcode 2.x (before iOS support)
Xcode 3.0 - Xcode 4.x
Xcode 5.0 - 6.x (since arm64 support)
Xcode 7.0 - 7.x (since Swift 2.0 support)
Version history     
VersionminOS Xto runOS X SDK(s)iOS SDK(s) includedother SDK(s) includeddownloadable iOS Simulators
7.0
10.10.4OS X v10.11iOS 9(13A340)watchOS2iOS 8.4 + iOS 8.3 + iOS 8.2 + iOS 8.1
7.1 beta 2
iOS 9.1 beta (13B5119e)watchOS2;tvOSbeta
VersionminOS Xto runOS X SDK(s)iOS SDK(s) includedother SDK(s) includeddownloadable iOS Simulators

©️2020 CSDN 皮肤主题: 编程工作室 设计师:CSDN官方博客 返回首页